Getting Started With D-RATS
A Quick Start Guide

D-RATS is a free, easy to use, multi-platform program for data communications with D-STAR devices or through the
Internet. The software can be run on Windows, MacOS and Linux/UNIX computers. D-RATS provides many functions
including:

e Instant messaging style chat

e Addressable messaging with attachments to other online stations, SMTP email addresses, Winlink 2000
addresses

e Send forms (predefined forms included, define custom forms)

e Unattended file transfer (all file types)

e Position reporting with included maps

e Repeater proxy software links radio, Internet clients

Step 1 - Download and Install
Download the latest version of D-RATS at http://www.dstarinfo.com/drats.aspx for your operating system and install to

your computer. For Windows, there are two versions of D-RATS for 32 or 64-bit PCs and operating system. Download
and unzip to the desired folder.

Step 2 — Set Preferences
Prior to using D-RATS there are several preferences that must be configured. These can be accessed by selecting File >
Preferences:
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A list of configurable item groups will appear in the left hand column. The following subsections describe the options
contained in each group.


http://www.dstarinfo.com/drats.aspx

r& Config @1
= Preferences Callsign WAL
Paths Name John Dod|
GPs Sign-on Message Enabled | Online (D-RATS)
Appearance Sign-off Message Enabled | Going offline (D-RATS)
Chat Units Imperial lz‘
Sounds Show time in UTC Enabled
Messages Ping reply
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Transfers Blinktra_y on
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= Network Mew Chat Messages Enabled
TCP Gateway Incoming Files Enabled
TCP Forwarding Received Events [ Enabled
Outgeoing Email
Email Accounts
Emnail Access
l Save l [ Cancel ]

e Callsign: Normally, your FCC callsign is entered. Optionally, a tactical callsign may be used. The callsign will
identify the station for chat, messaging and file transfer. When sending to this station the callsign entered
above is used to address the station.

o Name: Enter your name or location (ex. EOC, Shelter 1)

For a quick start, leave all other information at its default value.

Step 3 — Set Paths

Under Paths, you may leave these at their default value or define a different folder. The important one is the File
Transfer Path. This folder is used in File Transfers as your local location for remote stations to view and download your
files. Files uploaded to your station are placed here.
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Step 4 - Define Radios

In this section, you will define the connections D-RATS will use to communicate. If connecting to a D-STAR radio, the
GPS settings must be disabled in the menus of the radio. The table below provides the information for most Icom radios
needed to define a radio in this section and set the menu selections.

Radio Rate Radio settings required for D-RATS functions Updated 12/5/2014
9600

ID-51 Plus, Note: Fast Data only works with another ID-51A Plus or ID-5100A with firmware update)

Anniversary GPS>GPS SET>GPS Select>OFF, GPS>GPS TX Mode = OFF, GPS>GPS Auto TX = OFF, GPS>GPS

Edition Set>GPS Out = OFF, DV Set>DV Data TX = Auto, DV SET>DV Fast Data>Fast Data>ON, Function>ClI-

(Fast Data) V>CI-V (Data Jack)>OFF

;IL:)r;:lj\.l:rl'::'r 9600 GPS>GPS SET>GPS Select>OFF, GPS>GPS TX Mode = OFF, GPS>GPS Auto TX = OFF, GPS>GPS

L. y Set>GPS Out = OFF, DV Set>DV Data TX = Auto, DV SET>DV Fast Data>Fast Data>OFF, Function>Cl-

Edition V>CI-V (Data Jack)>OFF

(Slow Data)

ID-31A/51A 9600

(standard GPS>GPS SET>GPS Select>OFF, GPS>GPS TX Mode = OFF, GPS>GPS Auto TX = OFF, GPS>GPS

Edition) Set>GPS Out = OFF, DV Set>DV Data TX = Auto,

ID-5100A 9600 Using a Data Cable: Function>Data Speed=9600, DV Set>DV Data TX=Auto,

IC-7100A

¢-7100 9600 Using a USB Cable: GPS>GPS Select=0FF, GPS>GPS TX Mode=0FF, GPS>GPS Auto TX=OFF,
Connectors>USB2/DATA1Function>USB2 Function=DV Data, Connectors>USB2/Datal
Function>GPS Out=0FF, Connectors>USB2/Datal Function>DV Data/GPS Out Baud=9600
Using a Data Cable: GPS>GPS Select=0FF, GPS>GPS TX Mode=0FF, GPS>GPS Auto TX=0FF,
Connectors>USB2/DATA1Function>Datal Function=DV Data, Connectors>USB2/Datal
Function>GPS Out=0FF, Connectors>USB2/Datal Function>DV Data/GPS Out Baud=9600

IC-80AD 9600 | DATATX = AUTO, GPS-TX = OFF, GPS.ATX = OFF

Ic-us2 9600 | ATX = ATXON, SPD = SPD96

IC-va2 9600 | ATX = ATXON, SPD = SPD96

IC-91AD 38400 | pv DATA TX = AUTO, GPS TX = DISABLED, GPS AUTO TX = OFF

IC-92AD 38400 | pv DATA TX = AUTO, GPS TX = DISABLED, GPS AUTO TX = OFF

1C-2200 9600 | ATX = ATXON, SPD = SPD96

IC-2820 9600 DV DATA TX = AUTO, GPS TX = DISABLED, GPS AUTO TX = OFF, UT123 must be installed

ID-800H 9600 | DVT = DVTAT, SPD = SPD96

ID-880H 9600 DV Set>DATATX = AUTO, GPS>GPS-TX = OFF, GPS>GPS.ATX = OFF

ID-1 19200 | pv DATA TX = AUTO, Cannot use PC application




To use D-RATS with a D-STAR radio, it must be defined in the Radio section of the Preferences as below.
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From the Config > Radio screen, click “Add” and select Type as
Serial if connection to the radio with a serial cable. This is the
normal connection type for a radio. Select the Serial Port that
your data cable connects to on the computer. If you are using a
USB to Serial adapter or a serial cable with a USB connection, you
must locate the COM port number. In Windows, select START,
Control Panel, System and Device Manager. Under Ports, you will
see the COM Port assigned. The Baud Rate is dependent on the
radio settings. The default baud rate is shown in the table above
for each radio. You may add a Name to add a unique name to this
radio. Click Add to save the configuration.

On the Config > Radio screen, ensure that the box is checked for
the radio you have defined and wish to use. You should only have
one box checked at a time.



To connect to the Internet (without a D-STAR radio),
you will define and use a Repeater Proxy also known
as a Ratflector. These are used to connect D-RATS
Internet users together and may also connect to a D-
STAR radio to link RF users as well. The Ratflector
you use is determined by the D-RATS Administrators
in your area. A default Ratflector is usually defined in
D-RATS, but you may configure one just as you
configure a radio.

From the Config > Radio screen, click Add and select
Network. Under Host, add the address of the
Ratflector you intend to use. Port 9000 is the default
port used by most ratflectors. gaares.ratflector.com
is the Georgia ARES ratflector. Other ratflectors can
be found at http://dstarinfo.com/drats.aspx.

Click Add to save your configuration. On the Config > Radio screen, ensure that the box is checked for the radio you

have defined and wish to use.

Step 5 — Transfers

This section defines the parameters used for communicating between D-RATS stations. Under Block Size, the larger the
value, the more efficient the transfer is on a good connection. On a bad connection, setting this to be smaller reduces
the amount of data that must be re-sent in the event of a bit of corruption. Normally, the default value of 512 is good.
Normally the default values for the other settings are good for most situations. Make sure the “Remote file transfers”

box is checked.
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=l Preferences Block size 512 = | Revert
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Step 6— Messages


http://dstarinfo.com/drats.aspx

This section defines how messages are handled in D-RATS. The settings below are suggested. For the “My Winlink SSID”
setting, any valid SSID may be used.

rﬁ Config ﬁw
=l Preferences Automatically forward messages Enabled
Paths Queue flush interval 30 : seconds
GPS Station TTL 3600 ~ seconds
Appearance Include eriginal in reply [] Enabled
Chat Allow POP3 Gateway Enabled
Sounds Allow WLZK Gateway Enabled
m WL2K Connection Metwork Iz‘
o Radio WL2K Metwork Server serverwinlink.org EI Port | 8772 =
Transfers WL2K RMS Station on port
= Network My Winlink SSID 9 |
TCP Gateway POP3 Server [] Enabled on port| 9110 -
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Outgoing Email
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Save I l Cancel
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NOW LET’S USE D-RATS

Upon opening D-RATS, you will see four tabs across the top of the screen (Messages, Chat, Files and Event Log).
Whenever there is activity in any of the modes, the program border will flash and the tab with activity will turn blue.

Let’s start with Chat. Select the Chat tab. You may expand the screen size by grabbing a corner with your mouse and
dragging to the desired size. If you selected the Georgia Ratflector (gaares.d-rats.com) under Radios, a list of online
stations will appear on the right side of the screen under Stations. If none appear, with you mouse inside the area, right-
click and select Ping all Stations. You should see a list as stations reply to your ping. You can chat with the online
stations by typing your message in the area near the bottom of the screen as shown below.
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Next, let’s send a message to another station. Click on the Messages tab at the top. The Messages tab looks like many
email clients with a familiar Inbox, Outbox, etc., and New, Forward, Reply, etc.
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To send a regular message to another station, click New and either Memo or Email. Type in the Destination callsign .

Remember, this can either be the actual callsign or a tactical callsign. To ensure the correct destination, ping all stations
as in Chat and use the station name exactly as it appears. If the desired station is not online, you must still use the exact

destination callsign, but the message will not leave your Outbox until the stations is online.

Type a subject and your desired message and click Send. After a short delay, you message will begin to send as seen on
the staus line at the very bottom of the main screen.
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To send a form such as an ICS-213, select New and
the desired form from the list. A standard 1CS-213
form is included with D-RATS. Fill in the
information and select Send. Only the contents of
the form will be transmitted for efficiency and the
form will be populated on the receiving end.

The receiving station can click Print to view the
form as it actually appears for delivery to the
recipient.
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To open messages or forms received, click on Inbox and click on the desired message to open.




Our final Quick Start function is File Transfer. Click on Files to begin. The left hal of the screen shows any files on your
local computer in the folder you defined in the initial configuration for file transfers. Files that are transferred to your
station from a distant station will be stored there as well. A station must be online to send or receive files.

To upload a file to a distant station, first connect to that station. If there callsign/name shows on the right side of the
screen under Stations, you may select them in the Staion drop down box and click Connect. The station will show
connected on the status line at the bottom of the screen when connected. If there are files in the remote station’s
folder, you will see a list of files on the right half of the screen. Select the file you wish to upload to the distant station,
by highlighting it on the left side and click Upload. The file transfer will begin and progress will be shown on the status
line at the bottom.

% D-RATS: WB4QDX - B [E=nrE )
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| Messagesl Chat | Files | Event Log| Stations (3)
- N @ 3 S | GWI-ARES (4m)
Delete Upload Connect  Disconnect Download Delete MN3TSZ-W (4m)
Filename 4 Size 4 Date 4 Station: IZI Gwinnett ARES IZI WEB4QDX (7m)
| Apollo tonewav 44 KB 20:48:21 2010-04-24
| ARES Test_fldig3.tet 29KB  07:31:58 2010-06-02
| ARES_Test_fldigil et 4018 07:33:33 2010-06-02
| ARES_Test_fldigil.bet.wrap 461 B 07:29:38 2010-06-02
| ARES_Test_fldigi2.tet 19KE  12:54:43 2010-06-12
| ARES_Test_fldigi5.csv T2KE  12:52:12 2010-06-12
||l=) D-RATS diagram 7.JPG 356KB  19:51:05 2011-09-29
| D-RATS with analog radios.pdf 46.0KB  19:52:34 2011-09-29
| D-RATS_and_packet_radio 0.33.pdf 93.5KB 19:55:12 2011-09-29
| examples.desktop 167 B 21:27:30 2010-03-16
| Georgia Airport Codes.bd 11.0KE  20:45:52 2010-08-30
| GW ARES check in.bd 32B 20:54:06 2011-01-31
| 1091_20100510_WB4QDX.icf 109.8 KB 07:17:36 2010-05-13
| NameFilebd 12KE  20:40:22 2010-04-24
|| skywarnxml 28KB  2210:51 2012-12-26
| TestFilett 11KE  21:28:00 2010-03-28
| Trek chirp 11.wav 43 KB  20:45:09 2010-08-30
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To download a file from a distant station, again make sure you are connected to that station. Click on the file on the
right side of the screen hightlightin the file and click Download. Again, the file tansfer progress will be show at the
bottom of the screen, Be sure to Disconnect from the distant station when you are are finished tansfering files.

The Event Log tab provides a convenient log of all activities and provides a date and timestamp for each activity.

These are the basic functions of D-RATS. There are other functions and features that can be used. For more information
on the latest D-RATS features and development, join the D-RATS group at http://groups.io/g/d-rats.
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